summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Wilhelmi <wilhelmi@ira.uka.de>2002-07-03 15:41:52 +0000
committerSebastian Wilhelmi <wilhelmi@src.gnome.org>2002-07-03 15:41:52 +0000
commit9728e9f91f5d407c71ac60581e5e110af01734f8 (patch)
treeb20d1249429eedd8b8d5abdd37e4eff61b5bbe7e /configure.in
parent4d07a1fe1bd2cba6e157c0d93aaade7c433a92c6 (diff)
Fixed bugs in posix thread priority resolution. Also added AIX priorities.
2002-07-03 Sebastian Wilhelmi <wilhelmi@ira.uka.de> * configure.in: Fixed bugs in posix thread priority resolution. Also added AIX priorities. Fix from Laurent Vivier <Laurent.Vivier@bull.net>. (#82599). Merged from HEAD.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6701fae50..5714ab7ce 100644
--- a/configure.in
+++ b/configure.in
@@ -1480,13 +1480,20 @@ if test x"$have_threads" != xno; then
[Have function pthread_attr_setstacksize])],
[AC_MSG_RESULT(no)])
AC_MSG_CHECKING(for minimal/maximal thread priority)
- if test x"$posix_priority_min" = xnone; then
+ if test x"$posix_priority_min" = x; then
AC_EGREP_CPP(PX_PRIO_MIN,[#include <pthread.h>
PX_PRIO_MIN],,[
posix_priority_min=PX_PRIO_MIN
posix_priority_max=PX_PRIO_MAX])
fi
- if test x"$posix_priority_min" = xnone; then
+ if test x"$posix_priority_min" = x; then
+ # AIX
+ AC_EGREP_CPP(PTHREAD_PRIO_MIN,[#include <pthread.h>
+ PTHREAD_PRIO_MIN],,[
+ posix_priority_min=PTHREAD_PRIO_MIN
+ posix_priority_max=PTHREAD_PRIO_MIN])
+ fi
+ if test x"$posix_priority_min" = x; then
AC_EGREP_CPP(PRI_OTHER_MIN,[#include <pthread.h>
PRI_OTHER_MIN],,[
posix_priority_min=PRI_OTHER_MIN