summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Wilhelmi <wilhelmi@ira.uka.de>2002-01-22 09:50:24 +0000
committerSebastian Wilhelmi <wilhelmi@src.gnome.org>2002-01-22 09:50:24 +0000
commita9d13e865e54680eb05321f43d77222b14ecdff0 (patch)
tree542e6119a35ef23aded06b2bc3890329ca4e3f87 /configure.in
parentb23c1064bcf85bd31871c7931ce18f36cc43be4c (diff)
Get the right multithread option for GCC 3.0 and later. (#67583)
2002-01-22 Sebastian Wilhelmi <wilhelmi@ira.uka.de> * configure.in: Get the right multithread option for GCC 3.0 and later. (#67583)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index c691d7bdd..fd48737f3 100644
--- a/configure.in
+++ b/configure.in
@@ -1125,7 +1125,13 @@ if test x"$have_threads" != xno; then
*-aix*)
G_THREAD_CFLAGS="$G_THREAD_CFLAGS -D_THREAD_SAFE"
if test x"$GCC" = xyes; then
- G_THREAD_CFLAGS="$G_THREAD_CFLAGS -mthreads"
+ # GCC 3.0 and above needs -pthread
+ # GCC 2.x and below needs -mthreads
+ AC_TRY_COMPILE(,[#if __GNUC__ <= 2
+ bail out here
+ #endif],
+ G_THREAD_CFLAGS="$G_THREAD_CFLAGS -pthread",
+ G_THREAD_CFLAGS="$G_THREAD_CFLAGS -mthreads")
fi
;;
*-freebsd2.2*)