summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorKay Sievers <kay.sievers@vrfy.org>2010-09-03 15:12:19 +0200
committerLennart Poettering <lennart@poettering.net>2010-09-06 03:21:17 +0200
commit8a440f7441ac47e0828ce978c7f105dca845f1cf (patch)
tree0bb70e727f8dec7b142ce4d1e9aec1c3280cf71d /configure.in
parent929d9567d96992c01ebf8bbc0d40d9dc14677ca5 (diff)
systemd: enable the dbus service unconditionally
Since D-Bus is a core part of the OS don't make this service optional.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 8a7dc6f3..2d6e3ccf 100644
--- a/configure.in
+++ b/configure.in
@@ -1388,8 +1388,10 @@ AM_CONDITIONAL(DBUS_INIT_SCRIPTS_CYGWIN, test x$with_init_scripts = xcygwin)
AC_ARG_WITH([systemdsystemunitdir],
AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
[], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
-AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
-AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
+if test "x$with_systemdsystemunitdir" != xno; then
+ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+fi
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno ])
##### Set up location for system bus socket
if ! test -z "$with_system_socket"; then