summaryrefslogtreecommitdiff
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2015-03-05 13:06:10 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2015-03-05 13:54:15 +0100
commitcd8524ce0020337cf272959d4cdf67cf0d656384 (patch)
tree58f6b89e84f3cfebfaa34667998e3050a41d782f /cmake/CMakeLists.txt
parent939b3d97eea386216e9c1d45e20f3676be5ae8c6 (diff)
Move include file checks to ConfigureChecks.cmake for cmake build system.
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=85418 Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk>
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 14685da2..50949907 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -299,7 +299,6 @@ endif(NOT MSVC)
if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
option (DBUS_BUS_ENABLE_INOTIFY "build with inotify support (linux only)" ON)
if(DBUS_BUS_ENABLE_INOTIFY)
- check_include_file(sys/inotify.h HAVE_SYS_INOTIFY_H)
if(NOT HAVE_SYS_INOTIFY_H)
message(FATAL_ERROR "sys/inotify.h not found!")
endif(NOT HAVE_SYS_INOTIFY_H)
@@ -307,10 +306,6 @@ if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
elseif("${CMAKE_SYSTEM_NAME}" MATCHES ".*BSD")
option (DBUS_BUS_ENABLE_KQUEUE "build with kqueue support (FreeBSD only)" ON)
if(DBUS_BUS_ENABLE_KQUEUE)
- # cmake check a header by compiling a test program with
- # the header, sys/event.h needs stdint.h and sys/types.h
- # to work.
- check_include_files("stdint.h;sys/types.h;sys/event.h" HAVE_SYS_EVENT_H)
if(NOT HAVE_SYS_EVENT_H)
message(FATAL_ERROR "sys/event.h not found!")
endif(NOT HAVE_SYS_EVENT_H)