summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d663e61..4489fc9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,13 +6,19 @@ else
SUBDIRS_EXAMPLES =
endif
-SUBDIRS = \
+if BUILD_TESTS
+SUBDIRS_TESTS = tests
+else
+SUBDIRS_TESTS =
+endif
+
+SUBDIRS = \
gst \
common \
pkgconfig \
docs \
$(SUBDIRS_EXAMPLES) \
- tests
+ $(SUBDIRS_TESTS)
DIST_SUBDIRS = gst common pkgconfig docs examples tests