summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKoop Mast <kwm@rainbow-runner.nl>2014-06-15 21:15:51 +0200
committerTim-Philipp Müller <tim@centricular.com>2014-06-22 22:00:50 +0100
commita84406c09b937b135f772ee9555e61c3f0d52a9c (patch)
tree8214f5d7952cb4e06115a11741bf670255da2f07 /configure.ac
parentd9d4a91c62b8e2f021e5e8039bb1368f825b8d62 (diff)
configure: use -Werror to make the include GL and GLES2 header check guaranteed fatal
Clang will only give a warning for the redefinition of typedef GLenum. Since master is build with -Werror this will result in a build failure later in the gl plugin. Add -Werror to the test, so the test result is as expected. This will allow the gl plugins to build. https://bugzilla.gnome.org//show_bug.cgi?id=731692
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index be0bd66ad..214f39fa7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -851,6 +851,8 @@ if test "x$HAVE_GL" = "xyes" -a "x$HAVE_GLES2" = "xyes"; then
# endif
"
AC_MSG_CHECKING([whether it is possible to include both GL and GLES2 headers])
+ save_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS -Werror"
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[$GL_INCLUDES]], [[
#if !defined(GL_FALSE)
#error Failed to include GL headers
@@ -868,6 +870,7 @@ if test "x$HAVE_GL" = "xyes" -a "x$HAVE_GLES2" = "xyes"; then
HAVE_GLES2=no
fi
])
+ CPPFLAGS="$save_CPPFLAGS"
fi
#dnl Check for OpenGL, GLU