summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDave Airlie <airlied@redhat.com>2013-08-06 13:03:18 +1000
committerChris Wilson <chris@chris-wilson.co.uk>2013-08-06 09:31:21 +0100
commit6004870d53221caf05a330fcfc8a72e68b2b8898 (patch)
tree74ea1ea9471c5abd0be6336e94b42fd8eb986537 /configure.ac
parenta875ba39bea4a951e8cf1450ba9722b7cda95943 (diff)
configure.ac: fix dri enabled with kms only picked
Otherwise we'd fail saying DRI1 wasn't possible, when that is exactly what we asked for. [ickle: The breakage was introduced with commit bd6ffd1ad2f903215d2c631252e742a0f6893054 [2.21.14] Author: Chris Wilson <chris@chris-wilson.co.uk> Date: Sat Jul 27 15:33:19 2013 +0100 configure: Print a summary of compilation options which modified the search to only take place if UMS was enabled, but missed mollifying the resulting error.] Signed-off-by: Dave Airlie <airlied@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 104113e6..88f29ccd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -433,7 +433,7 @@ else
DRI1_CFLAGS=""
DRI1_LIBS=""
- if test "x$enable_dri" = "xyes"; then
+ if test "x$enable_dri" = "xyes" -a "x$KMS_ONLY" != "xyes"; then
AC_MSG_ERROR([DRI1 requested but prerequisites not found])
fi
fi