summaryrefslogtreecommitdiff
path: root/os/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2005-07-01 20:29:53 +0000
committerDaniel Stone <daniel@fooishbar.org>2005-07-01 20:29:53 +0000
commitded56b1a74e6b3e4c48054b7e142d924b19e6104 (patch)
treec2c9fb687494f559cb19e317290e272849c391ae /os/Makefile.am
parentaabb868920658c9d3979dc194c6bd9702171f101 (diff)
Adding initial build system.
Diffstat (limited to 'os/Makefile.am')
-rw-r--r--os/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/os/Makefile.am b/os/Makefile.am
new file mode 100644
index 000000000..934ee55c6
--- /dev/null
+++ b/os/Makefile.am
@@ -0,0 +1,40 @@
+noinst_LTLIBRARIES = libos.la
+
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+# k5auth.c \
+# lbxio.c \
+# rpcauth.c \
+# genalloca.c \
+# hpsocket.c \
+# secauth.c
+# xalloc.c
+
+if XCSECURITY
+XCSECURITY_SOURCES = secauth.c
+endif
+
+if XDMCP
+XDMCP_SOURCES = xdmcp.c
+endif
+
+XORG_SOURCES = log.c
+
+libos_la_SOURCES = \
+ WaitFor.c \
+ access.c \
+ auth.c \
+ connection.c \
+ io.c \
+ mitauth.c \
+ oscolor.c \
+ osdep.h \
+ osinit.c \
+ utils.c \
+ xdmauth.c \
+ xstrans.c \
+ xprintf.c \
+ $(XCSECURITY_SOURCES) \
+ $(XDMCP_SOURCES) \
+ $(XORG_SOURCES)