summaryrefslogtreecommitdiff
path: root/os/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-08-17 15:29:16 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-08-17 15:29:47 -0700
commit23fbd5292d356067e85e1eec4eb4f743532b0503 (patch)
tree3255e7d3429dba3fc13d9e98eeabcedf9fa75ebf /os/Makefile.am
parent6a32a96d8df184c3ace4847beb48fdcb846d2286 (diff)
Actually build Secure RPC authentication support (missed in modularization)
Diffstat (limited to 'os/Makefile.am')
-rw-r--r--os/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/os/Makefile.am b/os/Makefile.am
index 53b2d7f0c..d2a989782 100644
--- a/os/Makefile.am
+++ b/os/Makefile.am
@@ -3,9 +3,9 @@ noinst_LTLIBRARIES = libos.la libcwrapper.la
AM_CFLAGS = $(DIX_CFLAGS)
# FIXME: Add support for these in configure.ac
-SECURERPC_SRCS = rpcauth.c
INTERNALMALLOC_SRCS = xalloc.c
+SECURERPC_SRCS = rpcauth.c
XCSECURITY_SRCS = secauth.c
XDMCP_SRCS = xdmcp.c
STRLCAT_SRCS = strlcat.c strlcpy.c
@@ -28,6 +28,10 @@ libos_la_SOURCES = \
xprintf.c \
$(XORG_SRCS)
+if SECURE_RPC
+libos_la_SOURCES += $(SECURERPC_SRCS)
+endif
+
if XCSECURITY
libos_la_SOURCES += $(XCSECURITY_SRCS)
endif