summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <ssp@redhat.com>2012-07-01 16:59:53 -0400
committerSøren Sandmann Pedersen <ssp@redhat.com>2012-07-02 18:21:21 -0400
commitf9c91ee2f27eaea68d8c3a130bf7d4bc0c860834 (patch)
tree48506151ee52c0643f05ab426ba39bda139a4bd6 /configure.ac
parentcd7ecf548a9e8115226bf0fec174f3abc54becb5 (diff)
Use a compile-time constant for the "K" constraint in the MMX detection.
When compiling with -O0, gcc doesn't understand that in signed char x = 0; ... asm ("...", : "K" (x)); x is constant. Fix this by using an immediate constant instead of a variable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2b9d1ba2..36f423ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -351,12 +351,11 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
int main () {
__m64 v = _mm_cvtsi32_si64 (1);
__m64 w;
- signed char x = 0;
/* Some versions of clang will choke on K */
asm ("pshufw %2, %1, %0\n\t"
: "=y" (w)
- : "y" (v), "K" (x)
+ : "y" (v), "K" (5)
);
return _mm_cvtsi64_si32 (v);