summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.net>2013-04-10 11:51:37 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2013-04-12 23:05:59 +0100
commit5299a0cd65e3233dd61a5c8862519be4961f1b27 (patch)
tree443fe2cc58ccf8218576dc42be8044b7a3fda973 /configure.ac
parent3c1d9c6d41e4f209af5be1baa933234d6ef51560 (diff)
printf: deal with some of the HAVE_FOO used in the printf code
Probably needs some more work for MSVC.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ca57a1fea..8a6ad13d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -529,6 +529,27 @@ AC_CHECK_LIB(dl, dladdr,
LIBS="$LIBS -ldl")
CFLAGS="$save_cflags"
+dnl Check printf stuff
+if test "x${GST_DISABLE_GST_DEBUG}" != "xyes"; then
+ AC_TYPE_LONG_LONG_INT
+ AC_TYPE_UNSIGNED_LONG_LONG_INT
+
+ if test x$ac_cv_type_long_long_int$ac_cv_type_unsigned_long_long_int = xyesyes; then
+ AC_DEFINE([HAVE_LONG_LONG], [1], [Define to 1 if the system has the type long long])
+ fi
+
+ dnl /usr/share/aclocal/inttypes_h.m4 - ships with gettext apparently
+ gl_AC_HEADER_INTTYPES_H
+
+ dnl /usr/share/aclocal/stdint_h.m4 - ships with gettext apparently
+ gl_AC_HEADER_STDINT_H
+
+ AC_CHECK_TYPES(ptrdiff_t)
+
+ AC_TYPE_INTMAX_T
+ AC_TYPE_SIZE_T
+fi
+
dnl *** checks for dependency libraries ***
dnl GLib