summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2012-11-28 17:36:55 +0100
committerEdward Hervey <bilboed@bilboed.com>2012-11-28 18:21:00 +0100
commit465eb900a91a7cc23e8b741d8f8e62fe1c10f2f9 (patch)
treee5cdd98b7162258d4ad52ba3f8b6a74769ee2dd3 /configure.ac
parent3cf0a25e642c40309247ddb277857249b1a8561a (diff)
configure.ac: Update libtool versioning
In order for 1.x and 1.(x+1) versions to not invade on each other we need to have different lib versions. So we need a consistent and predictable scheme: library version number = MINOR * 100 + MICRO Ex: 1.0.0 => 0 (duh) 1.0.3 => 3 1.1.0 => 100 1.1.1 => 101 1.2.0 => 120 1.10.5 => 1005 ....
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b92112cea..f56624187 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,8 +55,16 @@ dnl - library source changed -> increment REVISION
dnl - interfaces added/removed/changed -> increment CURRENT, REVISION = 0
dnl - interfaces added -> increment AGE
dnl - interfaces removed -> AGE = 0
+dnl
+dnl Keep CURRENT as MINOR * 100 + MICRO
+dnl Ex : 1.0.0 => 0
+dnl 1.0.3 => 3
+dnl 1.1.0 => 100
+dnl 1.2.5 => 205
+dnl 1.10.9 (who knows) => 1009
+dnl
dnl sets GST_LT_LDFLAGS
-AS_LIBTOOL(GST, 2, 0, 2)
+AS_LIBTOOL(GST, 100, 0, 100)
dnl *** autotools stuff ****