summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2014-09-21 14:31:05 -0700
committerMatt Turner <mattst88@gmail.com>2014-09-25 13:52:55 -0700
commite4be17fd04adb5404207bcd260cdd26cbd931c3f (patch)
tree606709a144f05bf4d2eabf5add86b4bc0a401c9a /configure.ac
parent976464c210816ff0c90e2e24e766dda81193fc79 (diff)
ralloc: Mark ralloc functions with gcc's malloc attribute.
Cuts a few hundred bytes from the DRI drivers, so it must give gcc some extra information. Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 13b339eaaf..1d4a6ae891 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,6 +142,7 @@ AX_GCC_BUILTIN([__builtin_unreachable])
AX_GCC_FUNC_ATTRIBUTE([flatten])
AX_GCC_FUNC_ATTRIBUTE([format])
+AX_GCC_FUNC_ATTRIBUTE([malloc])
AX_GCC_FUNC_ATTRIBUTE([packed])
AM_CONDITIONAL([GEN_ASM_OFFSETS], test "x$GEN_ASM_OFFSETS" = xyes)