summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@redhat.com>2009-05-04 18:34:54 -0400
committerSøren Sandmann Pedersen <sandmann@redhat.com>2009-05-04 18:34:54 -0400
commite047f605e2e9ef4f23e63c38259c5ceb720060dc (patch)
tree11958ee9d7966e18ef9a178859f4de765dd90886 /test/Makefile.am
parentc882260d4b481283c3d59385bfa31bfeffc0a58f (diff)
Move all the GTK+ test code into its own file, utils.c
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 1beac5b..3889c56 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,5 +1,5 @@
TEST_LDADD = $(top_builddir)/pixman/libpixman-1.la
-INCLUDES = -I$(top_srcdir)/pixman -I$(top_builddir)/pixman
+INCLUDES = -I$(top_srcdir)/pixman -I$(top_builddir)/pixman
TESTPROGRAMS = \
region-test \
@@ -28,10 +28,17 @@ noinst_PROGRAMS = $(TESTPROGRAMS)
INCLUDES += $(GTK_CFLAGS)
-composite_test_LDADD = $(GTK_LDADD)
gradient_test_LDADD = $(GTK_LDADD)
+gradient_test_SOURCES = gradient-test.c utils.c
+
+composite_test_LDADD = $(GTK_LDADD)
+composite_test_SOURCES = composite-test.c utils.c
+
clip_test_LDADD = $(GTK_LDADD)
+clip_test_SOURCES = clip-test.c utils.c
+
trap_test_LDADD = $(GTK_LDADD)
+trap_test_SOURCES = trap-test.c utils.c
endif