summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@redhat.com>2009-07-09 01:47:19 -0400
committerSøren Sandmann Pedersen <sandmann@redhat.com>2009-07-09 01:47:19 -0400
commitbcf01c21d704717264011182e71cfaaf6922a437 (patch)
tree2b7c2cd00188c4bcf92beb8c814f45258380481c /test/Makefile.am
parent0db0430d1d410855863e669f0de9e8b5d26db7fd (diff)
Fix a couple of problems with the tests when HAVE_GTK is not defined.
- Make sure the non-gtk+ test programs are added to noinst_PROGRAMS when HAVE_GTK is not set. - Don't include glib.h in oob-test.c
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index cfe367e..d44e526 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -30,8 +30,6 @@ TESTPROGRAMS += \
convolution-test \
trap-test
-noinst_PROGRAMS = $(TESTPROGRAMS)
-
INCLUDES += $(GTK_CFLAGS)
gradient_test_LDADD = $(GTK_LDADD)
@@ -60,3 +58,5 @@ convolution_test_SOURCES = convolution-test.c utils.c utils.h
endif
+noinst_PROGRAMS = $(TESTPROGRAMS)
+