summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <ssp@redhat.com>2010-12-18 06:05:52 -0500
committerSøren Sandmann Pedersen <ssp@redhat.com>2010-12-20 19:37:11 -0500
commit3479050216a65e3ef6e966a8e801415145261216 (patch)
treed30ff25aee3f739dd510cfa4eaf7611e49b39e8d /test/Makefile.am
parent45a2d010773d05666e87b7a6502e8fcb25add4eb (diff)
Add a test compositing with the various PDF operators.
The test has floating point exceptions enabled, and currently fails with a divide-by-zero.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index bc92e65..19c4f80 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -6,6 +6,7 @@ INCLUDES = -I$(top_srcdir)/pixman -I$(top_builddir)/pixman
TESTPROGRAMS = \
a1-trap-test \
+ pdf-op-test \
region-test \
region-translate-test \
fetch-test \
@@ -28,6 +29,9 @@ oob_test_LDADD = $(TEST_LDADD)
scaling_crash_test_LDADD = $(TEST_LDADD)
region_translate_test_LDADD = $(TEST_LDADD)
+pdf_op_test_LDADD = $(TEST_LDADD)
+pdf_op_test_SOURCES = pdf-op-test.c utils.c utils.h
+
region_test_LDADD = $(TEST_LDADD)
region_test_SOURCES = region-test.c utils.c utils.h