summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@redhat.com>2008-03-27 10:07:11 -0400
committerSøren Sandmann Pedersen <sandmann@redhat.com>2008-03-27 10:07:11 -0400
commit0c33317f59b93f5cab348619b1c38a5dce97de94 (patch)
tree0150bba28dc925107abb7d790df9e1d36da9e4b4 /Makefile.am
parent0637671959b56bba93f39208c825c0d97e2f90df (diff)
Bump version to 0.10.0.
Also a bunch of changes to the release make targets
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am95
1 files changed, 63 insertions, 32 deletions
diff --git a/Makefile.am b/Makefile.am
index 9a2b991..87d212e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,24 +15,40 @@ RELEASE_OR_SNAPSHOT = $$(if test "x$(CAIRO_VERSION_MINOR)" = "x$$(echo "$(CAIRO_
RELEASE_CAIRO_HOST = $(USERNAME)@cairographics.org
RELEASE_CAIRO_DIR = /srv/cairo.freedesktop.org/www/releases
RELEASE_CAIRO_URL = http://cairographics.org/releases
+RELEASE_XORG_URL = http://xorg.freedesktop.org/archive/individual/lib
RELEASE_XORG_HOST = $(USERNAME)@xorg.freedesktop.org
RELEASE_XORG_DIR = /srv/xorg.freedesktop.org/archive/individual/lib
-RELEASE_ANNOUNCE_LIST = cairo-announce@cairographics.org
+RELEASE_ANNOUNCE_LIST = cairo-announce@cairographics.org, xorg-announce@lists.freedesktop.org
tar_gz = $(PACKAGE)-$(VERSION).tar.gz
tar_bz2 = $(PACKAGE)-$(VERSION).tar.bz2
-sha1_file = $(tar_gz).sha1
-gpg_file = $(sha1_file).asc
-$(sha1_file): $(tar_gz)
+sha1_tgz = $(tar_gz).sha1
+md5_tgz = $(tar_gz).md5
+
+sha1_tbz2 = $(tar_bz2).sha1
+md5_tbz2 = $(tar_bz2).md5
+
+gpg_file = $(sha1_tgz).asc
+
+$(sha1_tgz): $(tar_gz)
sha1sum $^ > $@
-$(gpg_file): $(sha1_file)
+$(md5_tgz): $(tar_gz)
+ md5sum $^ > $@
+
+$(sha1_tbz2): $(tar_bz2)
+ sha1sum $^ > $@
+
+$(md5_tbz2): $(tar_bz2)
+ md5sum $^ > $@
+
+$(gpg_file): $(sha1_tgz)
@echo "Please enter your GPG password to sign the checksum."
gpg --armor --sign $^
release-verify-newer:
- @echo -n "Checking that no $(VERSION) release already exists..."
+ @echo -n "Checking that no $(VERSION) release already exists at $(RELEASE_XORG_HOST)..."
@ssh $(RELEASE_XORG_HOST) test ! -e $(RELEASE_XORG_DIR)/$(tar_gz) \
|| (echo "Ouch." && echo "Found: $(RELEASE_XORG_HOST):$(RELEASE_XORG_DIR)/$(tar_gz)" \
&& echo "Refusing to try to generate a new release of the same name." \
@@ -44,52 +60,67 @@ release-verify-newer:
@echo "Good."
release-remove-old:
- $(RM) $(tar_gz) $(tar_bz2) $(sha1_file) $(gpg_file)
+ $(RM) $(tar_gz) $(tar_bz2) $(sha1_tgz) $(gpg_file)
-release-check: release-verify-newer release-remove-old distcheck
+ensure-prev:
+ @if [[ "$(PREV)" == "" ]]; then \
+ echo "" && \
+ echo "You must set the PREV variable on the make command line to" && \
+ echo "the git tag of the last release." && \
+ echo "" && \
+ echo "For example:" && \
+ echo " make PREV=pixman-0.7.3" && \
+ echo "" && \
+ false; \
+ fi
-release-upload: release-check $(tar_gz) $(tar_bz2) $(sha1_file) $(gpg_file)
+release-check: ensure-prev release-verify-newer release-remove-old distcheck
+
+release-upload: release-check $(tar_gz) $(tar_bz2) $(sha1_tgz) $(gpg_file)
mkdir -p releases
- scp $(tar_gz) $(sha1_file) $(gpg_file) $(RELEASE_CAIRO_HOST):$(RELEASE_CAIRO_DIR)
- scp $(tar_gz) $(tar_bz2) $(sha1_file) $(gpg_file) $(RELEASE_XORG_HOST):$(RELEASE_XORG_DIR)
- mv $(tar_gz) $(tar_bz2) $(sha1_file) $(gpg_file) releases
+ scp $(tar_gz) $(sha1_tgz) $(gpg_file) $(RELEASE_CAIRO_HOST):$(RELEASE_CAIRO_DIR)
+ scp $(tar_gz) $(tar_bz2) $(RELEASE_XORG_HOST):$(RELEASE_XORG_DIR)
ssh $(RELEASE_CAIRO_HOST) "rm -f $(RELEASE_CAIRO_DIR)/LATEST-$(PACKAGE)-[0-9]* && ln -s $(tar_gz) $(RELEASE_CAIRO_DIR)/LATEST-$(PACKAGE)-$(VERSION)"
git-tag -s -m "$(PACKAGE) $(VERSION) release" $(PACKAGE)-$(VERSION)
-release-publish-message: releases/$(sha1_file)
+release-publish-message: $(sha1_tgz) $(md5_tgz) $(sha1_tbz2) $(md5_tbz2) ensure-prev
@echo "Please follow the instructions in RELEASING to push stuff out and"
@echo "send out the announcement mails. Here is the excerpt you need:"
@echo ""
- @echo "Subject: $(PACKAGE) release $(VERSION) now available"
- @echo ""
+ @echo "Lists: $(RELEASE_ANNOUNCE_LIST)"
+ @echo "Subject: [ANNOUNCE] $(PACKAGE) release $(VERSION) now available"
@echo "============================== CUT HERE =============================="
- @echo "A new $(PACKAGE) release $(VERSION) is now available from:"
+ @echo "A new $(PACKAGE) release $(VERSION) is now available"
@echo ""
+ @echo "tar.gz:"
@echo " $(RELEASE_CAIRO_URL)/$(tar_gz)"
+ @echo " $(RELEASE_XORG_URL)/$(tar_gz)"
@echo ""
- @echo " which can be verified with:"
+ @echo "tar.bz2:"
+ @echo " $(RELEASE_XORG_URL)/$(tar_bz2)"
@echo ""
- @echo " $(RELEASE_CAIRO_URL)/$(sha1_file)"
- @echo -n " "
- @cat releases/$(sha1_file)
+ @echo "Hashes:"
+ @echo -n " MD5: "
+ @cat $(md5_tgz)
+ @echo -n " MD5: "
+ @cat $(md5_tbz2)
+ @echo -n " SHA1: "
+ @cat $(sha1_tgz)
+ @echo -n " SHA1: "
+ @cat $(sha1_tbz2)
@echo ""
+ @echo "GPG signature:"
@echo " $(RELEASE_CAIRO_URL)/$(gpg_file)"
@echo " (signed by `getent passwd "$$USER" | cut -d: -f 5 | cut -d, -f 1`)"
@echo ""
- @echo " Additionally, a git clone of the source tree:"
- @echo ""
- @echo " git clone git://git.freedesktop.org/git/pixman"
- @echo ""
- @echo " will include a signed $(PACKAGE)-$(VERSION) tag which points to a commit named:"
- @echo " `git cat-file tag $(PACKAGE)-$(VERSION) | grep ^object | sed -e 's,object ,,'`"
- @echo ""
- @echo " which can be verified with:"
- @echo " git verify-tag $(PACKAGE)-$(VERSION)"
- @echo ""
- @echo " and can be checked out with a command such as:"
- @echo " git checkout -b build $(PACKAGE)-$(VERSION)"
+ @echo "Git:"
+ @echo " git://git.freedesktop.org/git/pixman"
+ @echo " tag: $(PACKAGE)-$(VERSION)"
@echo ""
+ @echo "Log:"
+ @git-log --no-merges "$(PACKAGE)-$(PREV)".. | git shortlog | awk '{ printf "\t"; print ; }' | cut -b0-80
@echo "============================== CUT HERE =============================="
+ @echo ""
release-publish: release-upload release-publish-message