summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Fonseca <jfonseca@vmware.com>2015-06-08 13:10:25 +0100
committerJose Fonseca <jfonseca@vmware.com>2015-06-08 15:03:55 +0100
commit69c1da6393bbe75fcef41c683415668cdd9079c9 (patch)
treeaadee4480e00351335fb321694975ff72adc098f /CMakeLists.txt
parent34920fe9e4f6f908cac7bd8e6ed2af793fe7d1af (diff)
cmake,util: Disable MacOSX depracation warnings everywhere.
They can be quite distracting. Reviewed-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bcf6ea29f..edb599769 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -300,6 +300,14 @@ if (WIN32)
add_definitions (-D_USE_MATH_DEFINES)
endif (WIN32)
+if (APPLE)
+ # Don't warn about using deprecated OpenGL/GLU/GLUT functions.
+ # TODO: It would be nice to silence just the deprecation macros from
+ # OpenGLAvailability.h as opposed to all deprecated functions.
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-deprecated-declarations")
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-deprecated-declarations")
+endif ()
+
if (OPENGL_FOUND)
if (APPLE)
find_path(GLEXT_INCLUDE_DIR