summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e2f4941529..e0fac4858f 100644
--- a/meson.build
+++ b/meson.build
@@ -540,8 +540,8 @@ if dep_thread.found() and host_machine.system() == 'linux'
pre_args += '-DHAVE_PTHREAD'
endif
dep_elf = dependency('libelf', required : false)
-if not dep_elf.found()
- dep_elf = cc.find_library('elf', required : with_amd_vk) # TODO: clover, r600, radeonsi
+if not dep_elf.found() and (with_amd_vk or with_gallium_radeonsi) # TODO: clover, r600
+ dep_elf = cc.find_library('elf')
endif
dep_expat = dependency('expat')
# this only exists on linux so either this is linux and it will be found, or