summaryrefslogtreecommitdiff
path: root/src/glx/Makefile.am
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2014-08-17 17:22:22 +0100
committerJon TURNEY <jon.turney@dronecode.org.uk>2014-08-21 16:59:48 +0100
commit3fe7daec14282dc8e2f5c8cc547927e305009677 (patch)
tree86cd891da456165db47f92863fb06f6e16d2262f /src/glx/Makefile.am
parentea565108ae452611605834c9fff220952ad927fb (diff)
glx: Fix build since 679c2ef "glx/drisw: add support for DRI2rendererQueryExtension", when only building drisw renderer
v2: - Move dri*_query_renderer_* into their respective dri*_priv.h headers - Drop then unnneeded include of dri2.h from dri2_query_renderer.c - Rename dri2_query_renderer.c as dri_common_query_renderer.c, as it's contents now are used for more than dri[23] Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk> Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'src/glx/Makefile.am')
-rw-r--r--src/glx/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/glx/Makefile.am b/src/glx/Makefile.am
index cdd898efc8..451531237f 100644
--- a/src/glx/Makefile.am
+++ b/src/glx/Makefile.am
@@ -96,7 +96,8 @@ endif
if HAVE_DRICOMMON
libglx_la_SOURCES += \
xfont.c \
- dri_common.c
+ dri_common.c \
+ dri_common_query_renderer.c
endif
if HAVE_DRI2
@@ -104,8 +105,7 @@ libglx_la_SOURCES += \
dri_glx.c \
XF86dri.c \
dri2_glx.c \
- dri2.c \
- dri2_query_renderer.c
+ dri2.c
endif
if HAVE_DRI3