summaryrefslogtreecommitdiff
path: root/src/gallium/drivers/llvmpipe/Makefile.am
diff options
context:
space:
mode:
authorRoland Scheidegger <sroland@vmware.com>2013-05-16 22:58:33 +0200
committerRoland Scheidegger <sroland@vmware.com>2013-05-18 00:32:27 +0200
commitf3ad716e8f36fa1360703b73eafed1824c29db6e (patch)
tree4747f39433efe6f013942dc2a5d5788d0ad9300d /src/gallium/drivers/llvmpipe/Makefile.am
parent87978518e996d02e055174d7152fff150fe3cd13 (diff)
llvmpipe: get rid of unused tiled/linear logic
We do rendering to linear color buffers for quite some time, and since switching to linear depth buffers all the tiled/linear logic was unused. So get rid of (most) of it - there's still some LAYOUT_NONE things and late allocation of resources which probably could be simplified. Reviewed-by: Jose Fonseca <jfonseca@vmware.com>
Diffstat (limited to 'src/gallium/drivers/llvmpipe/Makefile.am')
-rw-r--r--src/gallium/drivers/llvmpipe/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/gallium/drivers/llvmpipe/Makefile.am b/src/gallium/drivers/llvmpipe/Makefile.am
index f1ba5d1247..9059053b44 100644
--- a/src/gallium/drivers/llvmpipe/Makefile.am
+++ b/src/gallium/drivers/llvmpipe/Makefile.am
@@ -72,8 +72,7 @@ libllvmpipe_la_SOURCES = \
lp_state_vs.c \
lp_surface.c \
lp_tex_sample.c \
- lp_texture.c \
- lp_tile_image.c
+ lp_texture.c
libllvmpipe_la_LDFLAGS = $(LLVM_LDFLAGS)