summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNicolai Hähnle <nicolai.haehnle@amd.com>2016-10-31 11:56:09 +0100
committerNicolai Hähnle <nicolai.haehnle@amd.com>2016-11-03 10:06:24 +0100
commit2ff5df8f5097d25899996ea344d09be5c76de323 (patch)
treeee4f18b3a3b3a2a635b2c95400ca8300e995e50f /src/Makefile.am
parent8eabee9ec0c164bd18babfe15311db14040ad337 (diff)
amd/common: build also for gallium drivers
At least when LLVM is used, which is basically always (unless you're only building r600 without OpenCL). Reviewed-by: Dave Airlie <airlied@redhat.com> Reviewed-by: Marek Olšák <marek.olsak@amd.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1347120f18..630409c822 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -78,6 +78,10 @@ if HAVE_AMD_DRIVERS
SUBDIRS += amd
endif
+if NEED_RADEON_LLVM
+SUBDIRS += amd/common
+endif
+
if HAVE_INTEL_DRIVERS
SUBDIRS += intel
endif
@@ -126,7 +130,6 @@ endif
# Requires wayland-drm
if HAVE_RADEON_VULKAN
-SUBDIRS += amd/common
SUBDIRS += amd/vulkan
endif