summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-09-30 14:04:28 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-10-16 16:32:43 -0700
commitb154b44ae342eaff3b0c2f4f46138742b5dfafe8 (patch)
treef066f60cd0124bc3514d232539fbb91e96012574 /meson.build
parent66c94b9313a697ce8f2b222f4ba353035e4b8726 (diff)
meson: build radeonsi gallium driver
This hooks up the bits necessary to build gallium dri drivers, with radeonSI as the first example driver. This isn't tested yet. v4: - drop radeonsi generated header from sources. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric at anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e2f4941529..e0fac4858f 100644
--- a/meson.build
+++ b/meson.build
@@ -540,8 +540,8 @@ if dep_thread.found() and host_machine.system() == 'linux'
pre_args += '-DHAVE_PTHREAD'
endif
dep_elf = dependency('libelf', required : false)
-if not dep_elf.found()
- dep_elf = cc.find_library('elf', required : with_amd_vk) # TODO: clover, r600, radeonsi
+if not dep_elf.found() and (with_amd_vk or with_gallium_radeonsi) # TODO: clover, r600
+ dep_elf = cc.find_library('elf')
endif
dep_expat = dependency('expat')
# this only exists on linux so either this is linux and it will be found, or