summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-09-30 13:48:34 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-10-16 16:32:43 -0700
commit66c94b9313a697ce8f2b222f4ba353035e4b8726 (patch)
tree528388ab26ab635d6351e4ef4066edcdd217ceda /meson.build
parent66f97f6640f5316b36177fd1053f0027eb6ec6cc (diff)
meson: build gallium winsys for dri, null, and wrapper
Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric at anholt.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ebaf2d957f..e2f4941529 100644
--- a/meson.build
+++ b/meson.build
@@ -523,10 +523,14 @@ else
dep_clock = cc.find_library('rt')
endif
+with_gallium_drisw_kms = false
dep_libdrm = dependency('libdrm', version : '>= 2.4.75',
required : with_dri2 or with_dri3)
if dep_libdrm.found()
pre_args += '-DHAVE_LIBDRM'
+ if with_dri_platform == 'drm' and with_dri
+ with_gallium_drisw_kms = true
+ endif
endif
# TODO: some of these may be conditional