summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-12-07 14:42:00 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2017-05-19 19:46:55 +0100
commitb496fc29327a9dfb10a33ed0d6db72f1310fb88a (patch)
treef19a87e1a9abbd2347e13344e12de14ddbeb9796 /configure.ac
parent037e9d37b4985e432a48b52f413ac4ba36ab7053 (diff)
configure: error out if building XVMC w/o supported platform
Cc: <mesa-stable@lists.freedesktop.org> Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 95ecaabd62..88c8753343 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2063,6 +2063,12 @@ fi
AM_CONDITIONAL(HAVE_ST_XA, test "x$enable_xa" = xyes)
if echo $platforms | grep -q "x11"; then
+ have_xvmc_platform=yes
+else
+ have_xvmc_platform=no
+fi
+
+if echo $platforms | grep -q "x11"; then
have_vdpau_platform=yes
else
have_vdpau_platform=no
@@ -2084,7 +2090,7 @@ dnl
dnl Gallium G3DVL configuration
dnl
if test -n "$with_gallium_drivers" -a "x$with_gallium_drivers" != xswrast; then
- if test "x$enable_xvmc" = xauto; then
+ if test "x$enable_xvmc" = xauto -a "x$have_xvmc_platform" = xyes; then
PKG_CHECK_EXISTS([xvmc >= $XVMC_REQUIRED], [enable_xvmc=yes], [enable_xvmc=no])
fi
@@ -2120,6 +2126,9 @@ fi
AM_CONDITIONAL(NEED_GALLIUM_VL_WINSYS, test "x$need_gallium_vl_winsys" = xyes)
if test "x$enable_xvmc" = xyes; then
+ if test "x$have_xvmc_platform" != xyes; then
+ AC_MSG_ERROR([XVMC requires the x11 platforms])
+ fi
PKG_CHECK_MODULES([XVMC], [xvmc >= $XVMC_REQUIRED])
gallium_st="$gallium_st xvmc"
fi