summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@imgtec.com>2017-07-14 11:14:28 +0100
committerEric Engestrom <eric.engestrom@imgtec.com>2017-07-14 13:23:54 +0100
commit8821ef4be1009328fc0bbf651feda6377efcd6b6 (patch)
tree8ed60ac2e960ff500164f1f43463b5e0191e7d0a /configure.ac
parentb50b4b6f84dc990b870d2f6cf59fd758c1607fa0 (diff)
configure: only install khrplatform.h if needed
khrplatform.h is only used by EGL and GLES; let's only install it when one of those is enabled. Cc: mesa-stable@lists.freedesktop.org Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 61d98e28e0..46fcd8f3fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1291,6 +1291,9 @@ AM_CONDITIONAL(HAVE_OPENGL_ES2, test "x$enable_gles2" = xyes)
AM_CONDITIONAL(NEED_OPENGL_COMMON, test "x$enable_opengl" = xyes -o \
"x$enable_gles1" = xyes -o \
"x$enable_gles2" = xyes)
+AM_CONDITIONAL(NEED_KHRPLATFORM, test "x$enable_egl" = xyes -o \
+ "x$enable_gles1" = xyes -o \
+ "x$enable_gles2" = xyes)
# Validate GLX options
if test "x$enable_glx" = xyes; then