summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-12-05 19:02:28 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2016-12-09 19:21:41 +0000
commitb83153e77b08ac82160f6281424878abacd97e31 (patch)
tree13741f3ebdbf7e48dbfb4de0ed667c32d4818f88 /configure.ac
parent0715ba4be6ff4633ba9623cec53861474ce1a528 (diff)
configure: enable glx-tls by default
In the (not too) distant future we'd want to remove this option and effectively drop the other codepath(s) we have in our dispatch. Linux distributions have been using --enable-glx-tls for a number of years. Some/most BSD platforms still don't support this, yet this should serve as an encouragement to move things forwards. Note: we had many bug reports were opened due to the wrong default option. See the list below for details. v2: - Correct default option in help string (Andreas) - Add bugzilla references. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=70623 Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=72902 Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=73778 Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=89043 Cc: Jean-Sébastien Pédron <dumbbell@FreeBSD.org> Cc: Jonathan Gray <jsg@jsg.id.au> Cc: mesa-maintainers@lists.freedesktop.org Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Eric Anholt <eric@anholt.net> Reviewed-by: Andreas Boll <andreas.boll.dev@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index adca49d31e..56e91f0078 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1705,9 +1705,9 @@ dnl
AC_ARG_ENABLE([glx-tls],
[AS_HELP_STRING([--enable-glx-tls],
- [enable TLS support in GLX @<:@default=disabled@:>@])],
+ [enable TLS support in GLX @<:@default=enabled@:>@])],
[GLX_USE_TLS="$enableval"],
- [GLX_USE_TLS=no])
+ [GLX_USE_TLS=yes])
AC_SUBST(GLX_TLS, ${GLX_USE_TLS})
AS_IF([test "x$GLX_USE_TLS" = xyes -a "x$ax_pthread_ok" = xyes],