summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTobias Droste <tdroste@gmx.de>2016-12-08 03:03:35 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2017-01-18 13:23:00 +0000
commitadd9066eb06626f5bee032d1ed982fe93f5b2bd7 (patch)
tree6fe1c815e2861e084926b8b250efe5db69aa1511 /configure.ac
parent903eb09b5fb78d47d0f8a4bdf826a113ca2aff40 (diff)
configure.ac: Rename MESA_LLVM to FOUND_LLVM
This renames MESA_LLVM to FOUND_LLVM and updates the config.log report to say if LLVM is found or not, to make clear that this does not mean that it is used. There are no MESA_LLVM users so drop the AC_SUBST. v2 [Emil] - Polish test: -a over && test, = over ==, unquiote xyes - other ? Signed-off-by: Tobias Droste <tdroste@gmx.de> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 10 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 3e2d79abdf..5e9d165aa2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -998,15 +998,15 @@ llvm_set_environment_variables() {
fi
DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DMESA_LLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
- MESA_LLVM=1
+ FOUND_LLVM=yes
else
- MESA_LLVM=0
+ FOUND_LLVM=no
LLVM_VERSION_INT=0
fi
}
llvm_check_version_for() {
- if test "x$MESA_LLVM" = x0; then
+ if test "x$FOUND_LLVM" = xno; then
AC_MSG_ERROR([LLVM $1 or newer is required for $2])
return
fi
@@ -1066,7 +1066,6 @@ radeon_llvm_check() {
llvm_set_environment_variables
-AC_SUBST([MESA_LLVM])
AC_SUBST([LLVM_BINDIR])
AC_SUBST([LLVM_CFLAGS])
AC_SUBST([LLVM_CPPFLAGS])
@@ -2519,7 +2518,7 @@ if test -n "$with_gallium_drivers"; then
;;
xswrast)
HAVE_GALLIUM_SOFTPIPE=yes
- if test "x$MESA_LLVM" = x1 && test "x$enable_gallium_llvm" == "xyes"; then
+ if test "x$FOUND_LLVM" = xyes -a "x$enable_gallium_llvm" = xyes; then
HAVE_GALLIUM_LLVMPIPE=yes
fi
;;
@@ -2584,7 +2583,7 @@ dnl by calling llvm-config --libs ${DRIVER_LLVM_COMPONENTS}, but
dnl this was causing the same libraries to be appear multiple times
dnl in LLVM_LIBS.
-if test "x$MESA_LLVM" != x0; then
+if test "x$FOUND_LLVM" != xno; then
if ! $LLVM_CONFIG --libs ${LLVM_COMPONENTS} >/dev/null; then
AC_MSG_ERROR([Calling ${LLVM_CONFIG} failed])
@@ -2686,7 +2685,7 @@ AM_CONDITIONAL(NEED_RADEON_DRM_WINSYS, test "x$HAVE_GALLIUM_R300" = xyes -o \
AM_CONDITIONAL(NEED_WINSYS_XLIB, test "x$enable_glx" = xgallium-xlib)
AM_CONDITIONAL(NEED_RADEON_LLVM, test x$NEED_RADEON_LLVM = xyes)
AM_CONDITIONAL(HAVE_GALLIUM_COMPUTE, test x$enable_opencl = xyes)
-AM_CONDITIONAL(HAVE_GALLIUM_LLVM, test "x$MESA_LLVM" = x1 -a \
+AM_CONDITIONAL(HAVE_GALLIUM_LLVM, test "x$FOUND_LLVM" = xyes -a \
"x$enable_gallium_llvm" = xyes)
AM_CONDITIONAL(USE_VC4_SIMULATOR, test x$USE_VC4_SIMULATOR = xyes)
if test "x$USE_VC4_SIMULATOR" = xyes -a "x$HAVE_GALLIUM_ILO" = xyes; then
@@ -2972,12 +2971,12 @@ else
fi
echo ""
-if test "x$MESA_LLVM" = x1; then
- echo " llvm: yes"
+if test "x$FOUND_LLVM" = xyes; then
+ echo " llvm found: yes"
echo " llvm-config: $LLVM_CONFIG"
echo " llvm-version: $LLVM_VERSION"
else
- echo " llvm: no"
+ echo " llvm found: no"
fi
echo ""
@@ -3026,7 +3025,7 @@ echo " CFLAGS: $cflags"
echo " CXXFLAGS: $cxxflags"
echo " Macros: $defines"
echo ""
-if test "x$MESA_LLVM" = x1; then
+if test "x$FOUND_LLVM" = xyes; then
echo " LLVM_CFLAGS: $LLVM_CFLAGS"
echo " LLVM_CXXFLAGS: $LLVM_CXXFLAGS"
echo " LLVM_CPPFLAGS: $LLVM_CPPFLAGS"