summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRami Ylimäki <rami.ylimaki@vincit.fi>2010-06-15 14:44:38 +0200
committerJeremy Huddleston <jeremyhu@apple.com>2012-02-10 15:50:20 -0800
commit8e19cee3c16ed739380e4b79896a7d756d98c050 (patch)
tree57fefca3ffda5046a7b00751a3c557bc189ecf25 /configure.ac
parent4975887a30a2c8f1bbba9127eee17f7099c3ecd1 (diff)
Revert "os: Prevent backtrace from being stopped in noreturn functions."
This reverts commit 579715f830fbbca9e1ecb17dc18176132f5969e7. The patch is not needed anymore. I haven't encountered backtrace problems with GCC 4.3.3. Even if the problems still persisted, this commit should be removed and instead the definition of _X_NORETURN should be modified to be empty if GCC/ARM is used. However, currently it seems that ARM backtraces are OK even if _X_NORETURN is used and -mapcs-frame is not defined in CFLAGS. Signed-off-by: Rami Ylimäki <rami.ylimaki@vincit.fi> Reviewed-by: Jamey Sharp <jamey@minilop.net> (cherry picked from commit 2b364bf970b2ce6829af656990c33afd0d365f3c)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index 455c3dbf5..d098bff2f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -312,19 +312,6 @@ AC_CHECK_HEADER([execinfo.h],[
])]
)
-dnl ARM needs additional compiler flags for proper backtraces if GCC is
-dnl used. Compile a dummy program with the -mapcs-frame option. If it
-dnl succeeds, we know that we are building for ARM with GCC.
-old_CFLAGS="$CFLAGS"
-CFLAGS="-mapcs-frame"
-AC_COMPILE_IFELSE(
- AC_LANG_PROGRAM([[ ]]),
- ARM_BACKTRACE_CFLAGS="$CFLAGS",
- ARM_BACKTRACE_CFLAGS=""
-)
-CFLAGS="$old_CFLAGS"
-AC_SUBST(ARM_BACKTRACE_CFLAGS)
-
dnl ---------------------------------------------------------------------------
dnl Bus options and CPU capabilities. Replaces logic in
dnl hw/xfree86/os-support/bus/Makefile.am, among others.