summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-01-14 15:23:41 -0800
committerDylan Baker <dylan@pnwbakers.com>2019-01-24 19:14:50 +0000
commitc1efa240c91e78385e8e433af134289b006016d0 (patch)
tree28dbba6aa3bbc72e2b5ee9a601fbebc7abec49d3 /meson.build
parent7cb7f35bc76bf21d15ca4b1f4ee724e9ff1e2804 (diff)
meson: Add warnings and errors when using ICC
ICC tries to be helpful by not erroring when it sees something that it doesn't understand, which is completely the opposite of helpful. Meson 0.49.0 does much better at handling this by really trying to make ICC error, but there are some things in mesa that still get ignored until 0.49.1 v2: - Fix id check, which is 'intel' not 'icc' Cc: 18.3 <mesa-stable@lists.freedesktop.org> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> (v1)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 9 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 34e2a0325484..2d730708d067 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,4 @@
-# Copyright © 2017-2018 Intel Corporation
+# Copyright © 2017-2019 Intel Corporation
# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
@@ -162,6 +162,14 @@ with_gallium_svga = _drivers.contains('svga')
with_gallium_virgl = _drivers.contains('virgl')
with_gallium_swr = _drivers.contains('swr')
+if cc.get_id() == 'intel'
+ if meson.version().verson_compare('< 0.49.0')
+ error('Meson does not have sufficient support of ICC before 0.49.0 to compile mesa')
+ elif with_gallium_swr and meson.version().verson_compare('== 0.49.0')
+ warning('Meson as of 0.49.0 is sufficient for compiling mesa with ICC, but there are some caveats with SWR. 0.49.1 should resolve all of these')
+ endif
+endif
+
with_gallium = _drivers.length() != 0 and _drivers != ['']
if with_gallium and system_has_kms_drm