summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-11-29 11:50:30 +0000
committerEric Engestrom <eric.engestrom@intel.com>2018-12-04 16:22:51 +0000
commita0b14c1b0255578fdabf8492295e74124d5862ed (patch)
tree5e0dd137e10dbfec29d686a99f470020cb40a2cd /meson.build
parent6ae873b97d3b6be8855b70ae13fb31d95e948fcc (diff)
meson: skip asm check when asm is disabled
Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index df9043e03fd8..1aeef95f7229 100644
--- a/meson.build
+++ b/meson.build
@@ -917,7 +917,7 @@ endif
# case of cross compiling where we can use asm, and that's x86_64 -> x86 when
# host OS == build OS, since in that case the build machine can run the host's
# binaries.
-if meson.is_cross_build()
+if with_asm and meson.is_cross_build()
if build_machine.system() != host_machine.system()
# TODO: It may be possible to do this with an exe_wrapper (like wine).
message('Cross compiling from one OS to another, disabling assembly.')