summaryrefslogtreecommitdiff
path: root/src/dnsmasq-manager/tests
diff options
context:
space:
mode:
Diffstat (limited to 'src/dnsmasq-manager/tests')
-rw-r--r--src/dnsmasq-manager/tests/Makefile.am6
-rw-r--r--src/dnsmasq-manager/tests/Makefile.in12
-rw-r--r--src/dnsmasq-manager/tests/test-dnsmasq-utils.c2
3 files changed, 13 insertions, 7 deletions
diff --git a/src/dnsmasq-manager/tests/Makefile.am b/src/dnsmasq-manager/tests/Makefile.am
index 9c7f4ab5c..c6ce1cdaf 100644
--- a/src/dnsmasq-manager/tests/Makefile.am
+++ b/src/dnsmasq-manager/tests/Makefile.am
@@ -1,12 +1,12 @@
AM_CPPFLAGS = \
-I$(top_srcdir)/include \
- -I$(top_builddir)/include \
- -I${top_srcdir}/libnm-util \
- -I${top_builddir}/libnm-util \
+ -I${top_srcdir}/libnm-core \
+ -I${top_builddir}/libnm-core \
-I$(top_srcdir)/src/dnsmasq-manager \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/platform \
-DG_LOG_DOMAIN=\""NetworkManager"\" \
+ -DNETWORKMANAGER_COMPILATION \
-DNM_VERSION_MAX_ALLOWED=NM_VERSION_NEXT_STABLE \
$(GLIB_CFLAGS) \
-DTESTDIR="\"$(abs_srcdir)\""
diff --git a/src/dnsmasq-manager/tests/Makefile.in b/src/dnsmasq-manager/tests/Makefile.in
index 52301e3d9..d5f924163 100644
--- a/src/dnsmasq-manager/tests/Makefile.in
+++ b/src/dnsmasq-manager/tests/Makefile.in
@@ -204,6 +204,8 @@ AUTOCONF = @AUTOCONF@
AUTOHEADER = @AUTOHEADER@
AUTOMAKE = @AUTOMAKE@
AWK = @AWK@
+BLUEZ5_CFLAGS = @BLUEZ5_CFLAGS@
+BLUEZ5_LIBS = @BLUEZ5_LIBS@
CC = @CC@
CCDEPMODE = @CCDEPMODE@
CFLAGS = @CFLAGS@
@@ -327,6 +329,7 @@ NEWT_CFLAGS = @NEWT_CFLAGS@
NEWT_LIBS = @NEWT_LIBS@
NM = @NM@
NMEDIT = @NMEDIT@
+NM_CONFIG_DEFAULT_AUTH_POLKIT_TEXT = @NM_CONFIG_DEFAULT_AUTH_POLKIT_TEXT@
NM_MAJOR_VERSION = @NM_MAJOR_VERSION@
NM_MICRO_VERSION = @NM_MICRO_VERSION@
NM_MINOR_VERSION = @NM_MINOR_VERSION@
@@ -346,6 +349,7 @@ PACKAGE_TARNAME = @PACKAGE_TARNAME@
PACKAGE_URL = @PACKAGE_URL@
PACKAGE_VERSION = @PACKAGE_VERSION@
PATH_SEPARATOR = @PATH_SEPARATOR@
+PERL = @PERL@
PKG_CONFIG = @PKG_CONFIG@
PKG_CONFIG_LIBDIR = @PKG_CONFIG_LIBDIR@
PKG_CONFIG_PATH = @PKG_CONFIG_PATH@
@@ -372,7 +376,7 @@ SYSTEMD_INHIBIT_LIBS = @SYSTEMD_INHIBIT_LIBS@
SYSTEMD_LOGIN_CFLAGS = @SYSTEMD_LOGIN_CFLAGS@
SYSTEMD_LOGIN_LIBS = @SYSTEMD_LOGIN_LIBS@
SYSTEM_CA_PATH = @SYSTEM_CA_PATH@
-UDEV_BASE_DIR = @UDEV_BASE_DIR@
+UDEV_DIR = @UDEV_DIR@
USE_NLS = @USE_NLS@
UUID_CFLAGS = @UUID_CFLAGS@
UUID_LIBS = @UUID_LIBS@
@@ -453,13 +457,13 @@ with_resolvconf = @with_resolvconf@
with_valgrind = @with_valgrind@
AM_CPPFLAGS = \
-I$(top_srcdir)/include \
- -I$(top_builddir)/include \
- -I${top_srcdir}/libnm-util \
- -I${top_builddir}/libnm-util \
+ -I${top_srcdir}/libnm-core \
+ -I${top_builddir}/libnm-core \
-I$(top_srcdir)/src/dnsmasq-manager \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/platform \
-DG_LOG_DOMAIN=\""NetworkManager"\" \
+ -DNETWORKMANAGER_COMPILATION \
-DNM_VERSION_MAX_ALLOWED=NM_VERSION_NEXT_STABLE \
$(GLIB_CFLAGS) \
-DTESTDIR="\"$(abs_srcdir)\""
diff --git a/src/dnsmasq-manager/tests/test-dnsmasq-utils.c b/src/dnsmasq-manager/tests/test-dnsmasq-utils.c
index 07dbc0f72..f8120ffec 100644
--- a/src/dnsmasq-manager/tests/test-dnsmasq-utils.c
+++ b/src/dnsmasq-manager/tests/test-dnsmasq-utils.c
@@ -18,6 +18,8 @@
*
*/
+#include "config.h"
+
#include <glib.h>
#include <arpa/inet.h>