summaryrefslogtreecommitdiff
path: root/src/devices/wimax/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/devices/wimax/Makefile.am')
-rw-r--r--src/devices/wimax/Makefile.am12
1 files changed, 4 insertions, 8 deletions
diff --git a/src/devices/wimax/Makefile.am b/src/devices/wimax/Makefile.am
index def8bf62b..555b5ff2e 100644
--- a/src/devices/wimax/Makefile.am
+++ b/src/devices/wimax/Makefile.am
@@ -1,20 +1,16 @@
AM_CPPFLAGS = \
-I${top_srcdir}/src \
-I${top_builddir}/src \
- -I${top_srcdir}/src/logging \
-I${top_srcdir}/src/devices \
-I${top_srcdir}/src/platform \
- -I${top_builddir}/include \
-I${top_srcdir}/include \
- -I${top_builddir}/libnm-util \
- -I${top_srcdir}/libnm-util \
+ -I${top_builddir}/libnm-core \
+ -I${top_srcdir}/libnm-core \
-DG_LOG_DOMAIN=\""NetworkManager-wimax"\" \
+ -DNETWORKMANAGER_COMPILATION \
-DNM_VERSION_MAX_ALLOWED=NM_VERSION_NEXT_STABLE \
$(DBUS_CFLAGS) \
- $(POLKIT_CFLAGS) \
- $(IWMX_SDK_CFLAGS) \
- $(LIBNL_CFLAGS) \
- $(GUDEV_CFLAGS)
+ $(IWMX_SDK_CFLAGS)
pkglib_LTLIBRARIES = libnm-device-plugin-wimax.la