summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 64be5c852..c128368ce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,11 @@
SUBDIRS = \
marshallers \
+ include \
libnm-util \
libnm-glib \
- src \
- include \
introspection \
+ src \
callouts \
- system-settings \
cli \
tools \
policy \
@@ -28,6 +27,7 @@ EXTRA_DIST = \
DISTCHECK_CONFIGURE_FLAGS = \
--with-tests=yes \
--with-docs=yes \
+ --enable-more-warnings=yes \
--with-udev-dir=$$dc_install_base/lib/udev \
--with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
@@ -36,4 +36,5 @@ DISTCLEANFILES = intltool-extract intltool-merge intltool-update
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = NetworkManager.pc
-ACLOCAL_AMFLAGS = -I m4
+ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+