summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/23-rfkill_return_type.patch22
2 files changed, 27 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index a4065efd6..e616438e6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,10 @@
-network-manager (0.6.5-3) UNRELEASED; urgency=low
+network-manager (0.6.5-3) unstable; urgency=low
- * NOT RELEASED YET
+ * debian/patches/23-rfkill_return_type.patch
+ - The return type of the GetPower() method from Device.Killswitch has
+ changed from UINT32 to INT32 in hal-0.5.10. Fix the code accordingly.
- -- Michael Biebl <biebl@debian.org> Fri, 28 Sep 2007 21:33:25 +0200
+ -- Michael Biebl <biebl@debian.org> Mon, 22 Oct 2007 17:05:44 +0200
network-manager (0.6.5-2) unstable; urgency=low
diff --git a/debian/patches/23-rfkill_return_type.patch b/debian/patches/23-rfkill_return_type.patch
new file mode 100644
index 000000000..1e327d46b
--- /dev/null
+++ b/debian/patches/23-rfkill_return_type.patch
@@ -0,0 +1,22 @@
+Index: src/NetworkManager.c
+===================================================================
+--- src/NetworkManager.c (Revision 2974)
++++ src/NetworkManager.c (Arbeitskopie)
+@@ -339,7 +339,7 @@
+ {
+ DBusError err;
+ DBusMessage * reply = NULL;
+- guint32 status;
++ gint32 status;
+
+ g_return_if_fail (pcall != NULL);
+ g_return_if_fail (data != NULL);
+@@ -358,7 +358,7 @@
+ goto out;
+ }
+
+- if (!dbus_message_get_args (reply, &err, DBUS_TYPE_UINT32, &status, DBUS_TYPE_INVALID)) {
++ if (!dbus_message_get_args (reply, &err, DBUS_TYPE_INT32, &status, DBUS_TYPE_INVALID)) {
+ nm_info ("Error getting killswitch power arguments: %s - %s", err.name, err.message);
+ dbus_error_free (&err);
+ goto out;