summaryrefslogtreecommitdiff
path: root/src/tests/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2011-04-08 07:30:59 +0200
committerMichael Biebl <biebl@debian.org>2011-04-08 07:30:59 +0200
commitf75dd6fd1975146623052b843b182dc32c3fbe46 (patch)
tree05ba60b772670f038c9a1fbff940ec5d3e28d870 /src/tests/Makefile.am
parentc980bdf58dc973dd5617aaa6f9466f9e44fcbf58 (diff)
Imported Upstream version 0.8.998upstream/0.8.998
Diffstat (limited to 'src/tests/Makefile.am')
-rw-r--r--src/tests/Makefile.am29
1 files changed, 27 insertions, 2 deletions
diff --git a/src/tests/Makefile.am b/src/tests/Makefile.am
index 62612a0e1..296668aa9 100644
--- a/src/tests/Makefile.am
+++ b/src/tests/Makefile.am
@@ -6,7 +6,10 @@ INCLUDES = \
-I$(top_srcdir)/src \
-I$(top_builddir)/src
-noinst_PROGRAMS = test-dhcp-options test-policy-hosts
+noinst_PROGRAMS = \
+ test-dhcp-options \
+ test-policy-hosts \
+ test-wifi-ap-utils
####### DHCP options test #######
@@ -39,11 +42,33 @@ test_policy_hosts_LDADD = \
$(top_builddir)/src/libtest-policy-hosts.la \
$(GLIB_LIBS)
+####### wifi ap utils test #######
+
+test_wifi_ap_utils_SOURCES = \
+ test-wifi-ap-utils.c
+
+test_wifi_ap_utils_CPPFLAGS = \
+ $(GLIB_CFLAGS) \
+ $(DBUS_CFLAGS)
+
+test_wifi_ap_utils_LDADD = \
+ $(top_builddir)/libnm-util/libnm-util.la \
+ $(top_builddir)/src/libtest-wifi-ap-utils.la \
+ $(GLIB_LIBS) \
+ $(DBUS_LIBS)
+
+####### secret agent interface test #######
+
+EXTRA_DIST = test-secret-agent.py
+
+###########################################
+
if WITH_TESTS
-check-local: test-dhcp-options
+check-local: test-dhcp-options test-policy-hosts test-wifi-ap-utils
$(abs_builddir)/test-dhcp-options
$(abs_builddir)/test-policy-hosts
+ $(abs_builddir)/test-wifi-ap-utils
endif