summaryrefslogtreecommitdiff
path: root/src/supplicant-manager/tests/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2014-07-06 02:16:10 +0200
committerMichael Biebl <biebl@debian.org>2014-07-06 02:16:10 +0200
commit33491bc4279481db8ae47213e34a6d695a0e8830 (patch)
tree097d2b0fdff3fae6885381ae5e57a182cd8cbbba /src/supplicant-manager/tests/Makefile.am
parent59c3714a494c3b3765657c0551ad82842d98a7d2 (diff)
Imported Upstream version 0.9.10.0upstream/0.9.10.0
Diffstat (limited to 'src/supplicant-manager/tests/Makefile.am')
-rw-r--r--src/supplicant-manager/tests/Makefile.am19
1 files changed, 7 insertions, 12 deletions
diff --git a/src/supplicant-manager/tests/Makefile.am b/src/supplicant-manager/tests/Makefile.am
index 58132a602..9defe66b1 100644
--- a/src/supplicant-manager/tests/Makefile.am
+++ b/src/supplicant-manager/tests/Makefile.am
@@ -1,26 +1,21 @@
-if ENABLE_TESTS
-
-noinst_PROGRAMS = test-supplicant-config
-
-test_supplicant_config_CPPFLAGS = \
+AM_CPPFLAGS = \
-I$(top_srcdir)/include \
-I$(top_builddir)/include \
-I$(top_srcdir)/libnm-util \
-I$(top_builddir)/libnm-util \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/supplicant-manager \
+ -DG_LOG_DOMAIN=\""NetworkManager"\" \
+ -DNM_VERSION_MAX_ALLOWED=NM_VERSION_NEXT_STABLE \
$(GLIB_CFLAGS) \
$(DBUS_CFLAGS)
+noinst_PROGRAMS = test-supplicant-config
+
test_supplicant_config_SOURCES = \
test-supplicant-config.c
test_supplicant_config_LDADD = \
- $(top_builddir)/libnm-util/libnm-util.la \
- $(top_builddir)/src/supplicant-manager/libsupplicant-manager.la \
- $(DBUS_LIBS)
-
-check-local: test-supplicant-config
- $(abs_builddir)/test-supplicant-config
+ $(top_builddir)/src/libNetworkManager.la
-endif
+TESTS = test-supplicant-config