summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2014-04-02 22:02:34 +0200
committerMichael Biebl <biebl@debian.org>2014-04-02 23:04:57 +0200
commite020f43fd2bdd889e4a3c75685a63a6fe5fe7fc3 (patch)
treea5b63f86f6e77f342497214118f20e5d23f643c3
parent6d5a07a76bc1d531851c5adf25fbe38885bc855f (diff)
Move the initial ifstate file check into nm_manager_start ()
to make sure the NMManager object has been fully initialized. Closes: #730437
-rw-r--r--debian/changelog2
-rw-r--r--debian/patches/0003-Force-online-state-with-unmanaged-devices.patch29
2 files changed, 21 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index 9d5305981..1918954c0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,8 @@ network-manager (0.9.8.8-5) UNRELEASED; urgency=medium
* Add Depends on libpam-systemd since NetworkManager requires a properly
setup logind session. (Closes: #743128)
* Bump policykit-1 from Recommends to Depends.
+ * Move the initial ifstate file check into nm_manager_start () to make sure
+ the NMManager object has been fully initialized. (Closes: #730437)
-- Michael Biebl <biebl@debian.org> Tue, 01 Apr 2014 23:22:57 +0200
diff --git a/debian/patches/0003-Force-online-state-with-unmanaged-devices.patch b/debian/patches/0003-Force-online-state-with-unmanaged-devices.patch
index 0e4f91dbd..bd1c4bc85 100644
--- a/debian/patches/0003-Force-online-state-with-unmanaged-devices.patch
+++ b/debian/patches/0003-Force-online-state-with-unmanaged-devices.patch
@@ -8,11 +8,11 @@ online state to CONNECTED.
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=512286
---
- src/nm-manager.c | 102 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 102 insertions(+)
+ src/nm-manager.c | 104 +++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 104 insertions(+)
diff --git a/src/nm-manager.c b/src/nm-manager.c
-index 9c82d14..7dbba47 100644
+index 9c82d14..5e732e4 100644
--- a/src/nm-manager.c
+++ b/src/nm-manager.c
@@ -78,6 +78,8 @@
@@ -51,8 +51,8 @@ index 9c82d14..7dbba47 100644
if (nm_device_is_activating (dev))
new_state = NM_STATE_CONNECTING;
else if (new_state != NM_STATE_CONNECTING) {
-@@ -4090,6 +4105,65 @@ policy_activating_device_changed (GObject *object, GParamSpec *pspec, gpointer u
- }
+@@ -3887,6 +3902,65 @@ impl_manager_check_connectivity (NMManager *manager,
+ nm_auth_chain_add_call (chain, NM_AUTH_PERMISSION_NETWORK_CONTROL, TRUE);
}
+static void
@@ -114,10 +114,20 @@ index 9c82d14..7dbba47 100644
+ }
+}
+
- #define NM_PERM_DENIED_ERROR "org.freedesktop.NetworkManager.PermissionDenied"
- #define DEV_PERM_DENIED_ERROR "org.freedesktop.NetworkManager.Device.PermissionDenied"
+ void
+ nm_manager_start (NMManager *self)
+ {
+@@ -3949,6 +4023,9 @@ nm_manager_start (NMManager *self)
+ /* FIXME: remove when we handle bridges non-destructively */
+ g_hash_table_unref (priv->nm_bridges);
+ priv->nm_bridges = NULL;
++
++ /* Trigger ifupdown state file check */
++ check_ifstate_file (self);
+ }
-@@ -4506,6 +4580,17 @@ dispose (GObject *object)
+ static gboolean
+@@ -4506,6 +4583,17 @@ dispose (GObject *object)
g_object_unref (priv->fw_monitor);
}
@@ -135,7 +145,7 @@ index 9c82d14..7dbba47 100644
g_slist_free (priv->factories);
if (priv->timestamp_update_id) {
-@@ -4865,6 +4950,23 @@ nm_manager_init (NMManager *manager)
+@@ -4865,6 +4953,22 @@ nm_manager_init (NMManager *manager)
KERNEL_FIRMWARE_DIR);
}
@@ -154,7 +164,6 @@ index 9c82d14..7dbba47 100644
+ nm_log_warn (LOGD_CORE, "failed to monitor ifupdown state file '%s'.",
+ IFUPDOWN_STATE_FILE);
+ }
-+ check_ifstate_file (manager);
+
load_device_factories (manager);