summaryrefslogtreecommitdiff
path: root/libnm-glib/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'libnm-glib/tests/meson.build')
-rw-r--r--libnm-glib/tests/meson.build36
1 files changed, 36 insertions, 0 deletions
diff --git a/libnm-glib/tests/meson.build b/libnm-glib/tests/meson.build
new file mode 100644
index 000000000..8e0fc7bb1
--- /dev/null
+++ b/libnm-glib/tests/meson.build
@@ -0,0 +1,36 @@
+incs = [
+ top_inc,
+ shared_inc
+]
+
+deps = [
+ dbus_dep,
+ dbus_glib_dep,
+ glib_dep,
+ libnm_glib_dep,
+ libnm_util_dep
+]
+
+cflags = [
+ '-DNETWORKMANAGER_COMPILATION=NM_NETWORKMANAGER_COMPILATION_LIB_LEGACY',
+ '-DTEST_NM_SERVICE="@0@"'.format(join_paths(meson.source_root(), 'tools', 'test-networkmanager-service.py'))
+]
+
+test_units = [
+ 'test-nm-client',
+ 'test-remote-settings-client'
+]
+
+foreach test_unit: test_units
+ name = 'libnm-glib-' + test_unit
+
+ exe = executable(
+ name,
+ [test_unit + '.c', libnm_utils_enums_h] + shared_test_utils,
+ include_directories: incs,
+ dependencies: deps,
+ c_args: cflags
+ )
+
+ test(name, exe)
+endforeach