summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDylan Baker <baker.dylan.c@gmail.com>2014-06-25 16:07:27 -0700
committerDylan Baker <dylanx.c.baker@intel.com>2014-08-19 14:23:22 -0700
commit2baa07a1f0d95789bf7f215670ff530c71230b81 (patch)
tree058c4a5704970762ac7a790c5045bf5f5ea62cbd /CMakeLists.txt
parent2060aad48dcb5b90ed144f379780b10befe9a098 (diff)
Bump python version requirement to 2.7.x
Python 2.6.6 was the final feature release of the 2.6 branch, it was released in August 2010. Python 2.6.9 was the last security release, it was released in October 2013. There is no support from upstream for 2.6, either for bugs or security problems, OSX, linux, windows all have 2.7 available to them, as does VMWare in their environment. Since no one any longer has a hard 2.6 requirement going to 2.7 seems like a natural choice. It has more features, more modules, and better 3.x compatibility than 2.6 does. Signed-off-by: Dylan Baker <baker.dylan.c@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4a0cec2e0..14d292730 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -169,7 +169,7 @@ ENDIF()
# Check for presence of Python 2.6 or greater.
foreach(python_cmd python2 python)
execute_process(
- COMMAND ${python_cmd} -c "import sys; assert '2.6' <= sys.version < '3'"
+ COMMAND ${python_cmd} -c "import sys; assert '2.7' <= sys.version < '3'"
OUTPUT_QUIET
ERROR_QUIET
RESULT_VARIABLE python_version_check_error_code)