summaryrefslogtreecommitdiff
path: root/hw/xfree86/dri/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/dri/Makefile.am')
-rw-r--r--hw/xfree86/dri/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/hw/xfree86/dri/Makefile.am b/hw/xfree86/dri/Makefile.am
new file mode 100644
index 000000000..cdc1c8bf1
--- /dev/null
+++ b/hw/xfree86/dri/Makefile.am
@@ -0,0 +1,13 @@
+libdri_la_LTLIBRARIES = libdri.la
+libdri_la_CFLAGS = -I$(top_srcdir)/hw/xfree86/common -I$(top_srcdir)/hw/xfree86/os-support/bus -I$(top_srcdir)/GL/glx/ -I$(top_srcdir)/GL/include -DXF86DRI -DXORG_VERSION_CURRENT=\"100\"
+libdri_la_LDFLAGS = -module -avoid-version
+libdri_ladir = @moduledir@/extensions
+libdri_la_SOURCES = \
+ dri.c \
+ dri.h \
+ drimodule.c \
+ dristruct.h \
+ sarea.h \
+ xf86dri.c
+
+sdk_HEADERS = dri.h sarea.h dristruct.h xf86dri.h