summaryrefslogtreecommitdiff
path: root/hw/xfree86/dixmods/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/dixmods/Makefile.am')
-rw-r--r--hw/xfree86/dixmods/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/hw/xfree86/dixmods/Makefile.am b/hw/xfree86/dixmods/Makefile.am
index 361b71a79..0810c6b00 100644
--- a/hw/xfree86/dixmods/Makefile.am
+++ b/hw/xfree86/dixmods/Makefile.am
@@ -3,7 +3,7 @@ noinst_LTLIBRARIES = libdixmods.la
module_LTLIBRARIES = libbitmap.la libfb.la
# yes, this is a cheesy hack.
-AM_CFLAGS = -include xorg-config.h $(XORG_CFLAGS)
+AM_CFLAGS = $(XORG_CFLAGS) -include xorg-config.h
INCLUDES = $(XORG_INCS) -I$(top_srcdir)/afb -I$(top_srcdir)/mfb \
-I$(top_srcdir)/cfb -I$(top_srcdir)/dbe -I$(srcdir)/../loader \
-I$(top_srcdir)/miext/layer -I$(top_srcdir)/miext/shadow
@@ -32,7 +32,7 @@ libdixmods_la_SOURCES = \
$(top_srcdir)/Xext/xf86misc.c \
$(top_srcdir)/Xext/xf86vmode.c
-xkb%.c: $(srcdir)/ddx$*.c
+xkb%.c:
echo "#define XF86DDXACTIONS" > $@
echo "#include \"$(top_srcdir)/xkb/ddx$*.c\"" >> $@