summaryrefslogtreecommitdiff
path: root/hw/xfree86/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hw/xfree86/common/Makefile.am')
-rw-r--r--hw/xfree86/common/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/hw/xfree86/common/Makefile.am b/hw/xfree86/common/Makefile.am
index 0d5331ebe..5cb164a21 100644
--- a/hw/xfree86/common/Makefile.am
+++ b/hw/xfree86/common/Makefile.am
@@ -67,6 +67,11 @@ sdk_HEADERS = compiler.h fourcc.h xf86.h xf86Module.h xf86Opt.h \
DISTCLEANFILES = xf86Build.h
+# this is a hack for now. as above we don't have rules to build all of these
+# yet, but we want to make sure they all get into the distball. this should
+# eventually go away.
+DISTKBDSOURCES = xf86Kbd.c xf86KbdBSD.c xf86KbdLnx.c xf86KbdMach.c
+
EXTRA_DIST = \
atKeynames.h \
compiler.h \
@@ -96,6 +101,7 @@ EXTRA_DIST = \
xf86Build.h.in \
xf86Version.h \
xorgVersion.h \
- xf86Date.h
+ xf86Date.h \
+ $(DISTKBDSOURCES)
AM_CFLAGS = $(XORG_CFLAGS)