summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 3 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index e497e76b4..d379b3af5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1440,17 +1440,9 @@ UTILS_SYS_LIBS="${SYS_LIBS}"
AC_SUBST([UTILS_SYS_LIBS])
# The Xorg binary needs to export symbols so that they can be used from modules
-# Some platforms require extra flags to do this. gcc should set these flags
-# when -rdynamic is passed to it, other compilers/linkers may need to be added
-# here.
-if test "x$GCC" = "xyes"; then
- LD_EXPORT_SYMBOLS_FLAG="-rdynamic"
-fi
-case $host_os in
- openbsd*)
- LD_EXPORT_SYMBOLS_FLAG="-Wl,--export-dynamic"
- ;;
-esac
+# Some platforms require extra flags to do this. libtool should set the
+# necessary flags for each platform when -export-dynamic is passed to it.
+LD_EXPORT_SYMBOLS_FLAG="-export-dynamic"
AC_SUBST([LD_EXPORT_SYMBOLS_FLAG])
dnl Imake defines SVR4 on SVR4 systems, and many files check for it, so