summaryrefslogtreecommitdiff
path: root/hw/xfree86/dixmods/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2005-07-01 20:29:53 +0000
committerDaniel Stone <daniel@fooishbar.org>2005-07-01 20:29:53 +0000
commitded56b1a74e6b3e4c48054b7e142d924b19e6104 (patch)
treec2c9fb687494f559cb19e317290e272849c391ae /hw/xfree86/dixmods/Makefile.am
parentaabb868920658c9d3979dc194c6bd9702171f101 (diff)
Adding initial build system.
Diffstat (limited to 'hw/xfree86/dixmods/Makefile.am')
-rw-r--r--hw/xfree86/dixmods/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/hw/xfree86/dixmods/Makefile.am b/hw/xfree86/dixmods/Makefile.am
new file mode 100644
index 000000000..d346fdd7f
--- /dev/null
+++ b/hw/xfree86/dixmods/Makefile.am
@@ -0,0 +1,26 @@
+noinst_LTLIBRARIES = libdixmods.la
+
+module_LTLIBRARIES = libbitmap.la libfb.la
+
+# yes, this is a cheesy hack.
+AM_CFLAGS = -include xorg-config.h $(XORG_CFLAGS)
+INCLUDES = $(XORG_INCS) -I$(top_srcdir)/afb -I$(top_srcdir)/mfb \
+ -I$(top_srcdir)/cfb -I$(top_srcdir)/dbe -I$(srcdir)/../loader \
+ -I$(top_srcdir)/miext/layer -I$(top_srcdir)/miext/shadow
+
+libbitmap_la_SOURCES = bitmapmod.c
+libbitmap_la_LDFLAGS = -lXfont
+libfb_la_SOURCES = fbmodule.c
+
+libdixmods_la_SOURCES = \
+ afbmodule.c \
+ cfbmodule.c \
+ cfb16module.c \
+ cfb24module.c \
+ cfb32module.c \
+ mfbmodule.c \
+ miinitext.c \
+ laymodule.c \
+ shmodule.c \
+ $(top_srcdir)/Xext/xf86misc.c \
+ $(top_srcdir)/Xext/xf86vmode.c