summaryrefslogtreecommitdiff
path: root/hw/xfree86/dixmods/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2006-07-18 18:16:12 -0400
committerDaniel Stone <daniels@endtroducing.fooishbar.org>2006-07-18 18:17:38 -0400
commit84683f19b4d1c712281036bcabf8dc623e64b26a (patch)
tree94c61eca298da6f6200fcb8ba8a4d1009b1495b7 /hw/xfree86/dixmods/Makefile.am
parent881953813c7307f2aac4057b48d233e5f4a574cd (diff)
get rid of XFree86LOADER, XFree86Server, XFree86Module, and IN_MODULE
Get rid of almost all uses of these definitions. They're still defined for delinquent out-of-tree drivers, and also for the Mesa build. As well as for miinitext.c. But largely gone.
Diffstat (limited to 'hw/xfree86/dixmods/Makefile.am')
-rw-r--r--hw/xfree86/dixmods/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/hw/xfree86/dixmods/Makefile.am b/hw/xfree86/dixmods/Makefile.am
index 9023a0cb0..65dad8a86 100644
--- a/hw/xfree86/dixmods/Makefile.am
+++ b/hw/xfree86/dixmods/Makefile.am
@@ -31,7 +31,7 @@ fontsmoduledir = $(moduledir)/fonts
fontsmodule_LTLIBRARIES = libfreetype.la \
libtype1.la
-AM_CFLAGS = @XORG_CFLAGS@ @DIX_CFLAGS@ @SERVER_DEFINES@ @LOADER_DEFINES@
+AM_CFLAGS = @XORG_CFLAGS@ @DIX_CFLAGS@
INCLUDES = @XORG_INCS@ \
-I$(top_srcdir)/afb \
-I$(top_srcdir)/cfb \
@@ -64,6 +64,7 @@ libdbe_la_SOURCES = dbemodule.c
libfb_la_LDFLAGS = -avoid-version
libfb_la_LIBADD = $(top_builddir)/fb/libfb.la
libfb_la_SOURCES = $(top_builddir)/fb/fbcmap.c fbmodule.c
+libfb_la_CFLAGS = -DXFree86Server $(AM_CFLAGS)
libglx_la_LDFLAGS = -avoid-version
if AIGLX
@@ -93,6 +94,7 @@ libtype1_la_LDFLAGS = -avoid-version
libtype1_la_SOURCES = type1mod.c
libdixmods_la_SOURCES = $(top_srcdir)/mi/miinitext.c
+libdixmods_la_CFLAGS = -DXFree86LOADER $(AM_CFLAGS)
libxorgxkb_la_SOURCES = xkbVT.c xkbPrivate.c xkbKillSrv.c
libxorgxkb_la_LIBADD = $(top_builddir)/dix/libdix.la