summaryrefslogtreecommitdiff
path: root/hw/xfree86/dixmods/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <anholt@freebsd.org>2005-12-22 13:54:08 +0000
committerEric Anholt <anholt@freebsd.org>2005-12-22 13:54:08 +0000
commit2af7e94eab6847159a3439301ecc93c62a12b1a0 (patch)
tree1780eb819efe3d82bfb203aeade0c142becd1910 /hw/xfree86/dixmods/Makefile.am
parent0d7ec5c7d9b451066a079fe56bcc9722341a91ff (diff)
Adjust the rules for auto-generating some source files, so that they work
on both GNU make and FreeBSD's make.
Diffstat (limited to 'hw/xfree86/dixmods/Makefile.am')
-rw-r--r--hw/xfree86/dixmods/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/hw/xfree86/dixmods/Makefile.am b/hw/xfree86/dixmods/Makefile.am
index 1ed24fa94..623006079 100644
--- a/hw/xfree86/dixmods/Makefile.am
+++ b/hw/xfree86/dixmods/Makefile.am
@@ -111,12 +111,13 @@ libtype1_la_SOURCES = type1mod.c
libdixmods_la_SOURCES = $(top_srcdir)/mi/miinitext.c
-libxorgxkb_la_SOURCES = xkbVT.c xkbPrivate.c xkbKillSrv.c
+XKB_SOURCES = xkbVT.c xkbPrivate.c xkbKillSrv.c
+libxorgxkb_la_SOURCES = $(XKB_SOURCES)
libxtrap_la_LDFLAGS = -avoid-version
libxtrap_la_LIBADD = $(top_builddir)/XTrap/libxtrapmodule.la
libxtrap_la_SOURCES = xf86XTrapModule.c
-xkb%.c:
+$(XKB_SOURCES):
echo "#define XF86DDXACTIONS" > $@
- echo "#include \"$(top_srcdir)/xkb/ddx$*.c\"" >> $@
+ echo "#include \"$(top_srcdir)/xkb/ddx${@:xkb%=%}\"" >> $@