summaryrefslogtreecommitdiff
path: root/hw/kdrive/Makefile.am
diff options
context:
space:
mode:
authorAdam Jackson <ajax@benzedrine.nwnk.net>2007-04-26 15:28:04 -0400
committerAdam Jackson <ajax@benzedrine.nwnk.net>2007-04-26 15:28:04 -0400
commitae04f2cb0a068cdc1e519627bf745de0c9e4a85a (patch)
treefff7af26234f4d879a7d13e46f0e1a44a53a4daf /hw/kdrive/Makefile.am
parent6c8152d6ee9eeb21a68a8bbfed1540939e5bcd1f (diff)
Fix the 'relink' target for kdrive servers.
Diffstat (limited to 'hw/kdrive/Makefile.am')
-rw-r--r--hw/kdrive/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/hw/kdrive/Makefile.am b/hw/kdrive/Makefile.am
index e07804948..267d772e2 100644
--- a/hw/kdrive/Makefile.am
+++ b/hw/kdrive/Makefile.am
@@ -23,14 +23,20 @@ if KDRIVELINUX
LINUX_SUBDIRS = linux
endif
-SUBDIRS = \
- src \
- $(LINUX_SUBDIRS) \
+SERVER_SUBDIRS = \
$(XSDL_SUBDIRS) \
$(FBDEV_SUBDIRS) \
$(VESA_SUBDIRS) \
$(XEPHYR_SUBDIRS) \
$(XFAKE_SUBDIRS)
+SUBDIRS = \
+ src \
+ $(LINUX_SUBDIRS) \
+ $(SERVER_SUBDIRS)
+
DIST_SUBDIRS = vesa ati chips epson i810 mach64 mga neomagic nvidia pm2 r128 \
smi via fbdev sdl ephyr src linux fake sis300
+
+relink:
+ @for i in $(SERVER_SUBDIRS) ; do make -C $$i relink ; done