summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@neko.keithp.com>2006-11-04 17:41:25 -0800
committerKeith Packard <keithp@neko.keithp.com>2006-11-04 17:41:25 -0800
commit8b87ce19741753eafbd99e7093bc3dea8f26e838 (patch)
tree5510c26613b789f281245c9ab13c4e0a14298cba /configure.ac
parent7ffbe9d232e3a4621a204448d67e434736465cbe (diff)
Allow X server to build against libdrm 2.1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 195211cb9..cb194aee6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -619,6 +619,9 @@ if test "x$DRI" = xyes; then
PKG_CHECK_MODULES([DRIPROTO], [xf86driproto])
PKG_CHECK_MODULES([LIBDRM], [libdrm])
PKG_CHECK_MODULES([GL], [glproto >= 1.4.1])
+ PKG_CHECK_EXISTS(libdrm >= 2.2.0,
+ [AC_DEFINE([HAVE_LIBDRM_2_2], 1,
+ [Has version 2.2 (or newer) of the drm library])])
AC_SUBST(DRIPROTO_CFLAGS)
AC_SUBST(LIBDRM_CFLAGS)
AC_SUBST(GL_CFLAGS)