summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2007-05-24 11:00:04 -0700
committerEric Anholt <eric@anholt.net>2007-05-24 11:20:59 -0700
commit8f98be7db303bc3db650054efb86843c70114451 (patch)
treee8e97744e7e8f3edc15500df2b9a5d22491192db /configure.ac
parent9616a042855399f0ee9c6489ea824621ea5fee18 (diff)
Fix bswap detection on BSD (mis-added '_' in function names).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index d7d00e267..37199cf26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -123,19 +123,19 @@ b = __swap16(a);
], [SYS_ENDIAN__SWAP='yes'], [SYS_ENDIAN__SWAP='no'])
AC_MSG_RESULT([$SYS_ENDIAN__SWAP])
- AC_MSG_CHECKING([for bswap_16 variant of <sys/endian.h> byteswapping macros])
+ AC_MSG_CHECKING([for bswap16 variant of <sys/endian.h> byteswapping macros])
AC_LINK_IFELSE([AC_LANG_PROGRAM([
#include <sys/endian.h>
], [
int a = 1, b;
-b = bswap_16(a);
+b = bswap16(a);
])
], [SYS_ENDIAN_BSWAP='yes'], [SYS_ENDIAN_BSWAP='no'])
AC_MSG_RESULT([$SYS_ENDIAN_BSWAP])
if test "$SYS_ENDIAN_BSWAP" = "yes" ; then
USE_SYS_ENDIAN_H=yes
- BSWAP=bswap_
+ BSWAP=bswap
else
if test "$SYS_ENDIAN__SWAP" = "yes" ; then
USE_SYS_ENDIAN_H=yes